查看: 19226|回复: 322
打印 上一主题 下一主题

[倚天指标] 支撑与压力、波段顶底(有未来函数)源码

  [复制链接]

该用户从未签到

17

主题

485

帖子

0

贡献值

登峰造极

Rank: 10Rank: 10Rank: 10

现货币
264 枚
在线时间
3196 小时
楼主
跳转到指定楼层
发表于 2013-2-3 14:47:40 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式
游客,如果您要查看本帖隐藏内容请回复
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

签到天数: 127 天

[LV.7]常住居民III

3

主题

369

帖子

0

贡献值

渐入佳境

Rank: 6Rank: 6

现货币
1609 枚
在线时间
204 小时
推荐
发表于 2014-5-15 17:19:08 | 只看该作者
趋势线:MA(CLOSE,21),COLORFFFFFF,LINETHICK2;
生命线:MA(CLOSE,43),COLOR00FFFF,LINETHICK2;
牛熊分界线:MA
(CLOSE,250),COLOR0000FF,LINETHICK3;
TY:=C;
HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV
(TY,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV
(TY,2*10+1),10),10+1),10);
A:=REF(C,BARSLAST(HD));
B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
压力线:IF
(T1,A,A),COLORFF00FF,POINTDOT,LINETHICK1;
STICKLINE(T1,A,A,9,0),COLORFF00FF;
支撑线:IF
(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK1;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV
(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-
LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=MA(HHV(CLOSE-REF(CLOSE,1),0),34)/MA(ABS
(CLOSE-REF(CLOSE,1)),7)*100;
VAR9:=MA(HHV(CLOSE-REF(CLOSE,1),0),13)/MA(ABS
(CLOSE-REF(CLOSE,1)),13)*100;
VARA:=BARSCOUNT(CLOSE);
VARB:=VAR8<20 AND VAR9<23 AND VARA>35;
VARC:=VARB AND COUNT(VARB,1)=1;
VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VARE:=EMA(VARD,5);
VARF:=TROUGH(3,6,1)<4 AND CROSS(VARD,VARE);
VAR10:=IF(TROUGH(3,16,1)=0 AND
HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG
(3,6),1)<=REF(ZIG(3,6),2)
AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG
(3,6),1)>=REF(ZIG(3,6),2)
AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG
(3,22),1)<=REF(ZIG(3,22),2)
AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG
(3,22),1)>=REF(ZIG(3,22),2)
AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG
(3,51),1)<=REF(ZIG(3,51),2)
AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG
(3,51),1)>=REF(ZIG(3,51),2)
AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG
(3,72),1)<=REF(ZIG(3,72),2)
AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG
(3,72),1)>=REF(ZIG(3,72),2)
AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR1A:=EMA(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);
VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR1E:=EMA(VAR1D*0.97,3);
VAR1F:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV
(VAR1F,14));
VAR21:=CROSS(VAR1E,LOW);
买点1:=VAR10;
买点2:=(VAR11+VAR13+VAR15+VAR17);
卖点1:=(VAR12+VAR14+VAR16+VAR18),LINETHICK2;
VAR22:=买点1 AND VARF AND VARC AND VAR21 AND
VAR4<0 AND VAR5=0
AND VAR6=0 AND VAR20<(-110);
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR31:=MA(CLOSE,30);
VARB1:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC1:=INTPART(VARB1*100)/100;
VARD1:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE1:=EMA(VARD1,9);
VAR131:=REF(VARE1,1);
VAR141:=VARE1;
VAR151:=VAR141-VAR131;
VAR161:=REF(VARD1,1);
VAR171:=VARD1;
VAR181:=VAR171-VAR161;
VAR191:=OPEN;
VAR1A1:=CLOSE;
DRAWTEXT(买点1>0,L-0.01,'▲跟多'),colorred;
DRAWTEXT(买点2>0,L-0.01,'▲跟多'),COLORFF00FF;
DRAWTEXT(卖点1>0,H+0.1,'▼卖点'),COLOR00FF00;
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

该用户从未签到

0

主题

11

帖子

0

贡献值

初学乍练

Rank: 1

现货币
15 枚
在线时间
1 小时
推荐
发表于 2019-6-18 14:06:56 | 只看该作者
A1:=REF(C,1); A2:=SMA(MAX(C-A1,0),5,1)/SMA(ABS(C-A1),5,1)*1000; A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1)); A4:=A2-LLV(A2,10); A5:=(MA(A4,2)*3+A4*13)/16; A6:=IF(A5>13,MA(A5,2),A5)/6; RSI1:=SMA(MAX(C-A1,0),6,1)/SMA(ABS(C-A1),6,1)*100; RSI2:=SMA(MAX(C-A1,0),12,1)/SMA(ABS(C-A1),12,1)*100; RSI3:=SMA(MAX(C-A1,0),24,1)/SMA(ABS(C-A1),24,1)*100; 压力:=HHV(MA(RSI2,3),12); 支撑:=LLV(MA(RSI2,3),12); 中间HHV(MA(RSI2,3),12)+LLV(MA(RSI2,3),12))/2,COLORRED,LINETHICK2; STICKLINE(RSI2<支撑,中间,RSI2,1,0)COLORFF972F; STICKLINE(RSI2>=支撑 AND RSI2<中间,中间,RSI2,1,0)COLORFF972F; STICKLINE(RSI2>=中间 AND RSI2<压力,中间,RSI2,2,0)COLORRED; STICKLINE(RSI2>=压力,中间,RSI2,2,0)COLORRED; B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS ("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)); DRAWTEXT(B3,RSI2,'←底背'); B1:=RSI1>=RSI2 AND RSI2>=RSI3; S1:=RSI1<RSI2 AND RSI2<RSI3; BS1:=NOT(RSI1>=RSI2 AND RSI2>=RSI3)AND NOT(RSI1<RSI2 AND RSI2<RSI3); STICKLINE(B1,80,82,2,1)COLORRED; STICKLINE(S1,80,82,2,1)COLORGREEN; STICKLINE(BS1,80,82,2,1)COLORYELLOW; 短线:IF(CROSS(A6,1) AND (A6<30)AND RSI2<35 AND RSI2>=支撑 AND RSI2<中间,30,20),COLORMAGENTA,LINETHICK2; AA:=VOL/((HIGH-LOW)*2-(ABS(CLOSE-OPEN)))*100; 主动买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*(HIGH-OPEN+CLOSE-LOW),VOL/2)); 主动卖盘:=IF(CLOSE>OPEN,-AA*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,-AA*(HIGH-LOW),-VOL/2)); 买卖比:=主动买盘/主动卖盘; 卖盘:=VOL-主动买盘; 卖盘大:=(卖盘-主动买盘)/卖盘>0.6; 买盘大:=(主动买盘-卖盘)/主动买盘>0.6;
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

该用户从未签到

2

主题

225

帖子

0

贡献值

初窥堂奥

Rank: 4

现货币
2165 枚
在线时间
52 小时
推荐
发表于 2014-8-28 15:00:10 | 只看该作者
N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
CJ_K:MA(K,15),LINETHICK2;
CJ_D:MA(D,15),LINETHICK2;
CJ_J:MA(J,15),LINETHICK2;
DRAWICON(CROSS(CJ_K,CJ_D);;CJ_D<30,CJ_K*0.80,11);
DRAWICON(CROSS(CJ_D,CJ_K);;CJ_D>70,CJ_K*1.05,12);
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

签到天数: 3 天

[LV.2]偶尔看看I

17

主题

626

帖子

0

贡献值

自成一派

Rank: 8Rank: 8

现货币
765 枚
在线时间
738 小时
5#
发表于 2013-2-3 15:39:04 | 只看该作者
这公式我应该有了[s:541]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

该用户从未签到

0

主题

228

帖子

0

贡献值

初窥堂奥

Rank: 4

现货币
84 枚
在线时间
75 小时
6#
发表于 2013-2-3 16:10:30 | 只看该作者
[s:541][s:541][s:541]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

该用户从未签到

18

主题

1061

帖子

0

贡献值

功行圆满

Rank: 9Rank: 9Rank: 9

现货币
338 枚
在线时间
1689 小时
7#
发表于 2013-2-3 16:14:42 | 只看该作者
[s:538] [s:542] [s:539] [s:539]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

该用户从未签到

0

主题

144

帖子

0

贡献值

初窥堂奥

Rank: 4

现货币
3 枚
在线时间
184 小时
8#
发表于 2013-2-3 16:15:15 | 只看该作者
田田田田田田田田田田田田田田田
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

该用户从未签到

12

主题

388

帖子

0

贡献值

功行圆满

Rank: 9Rank: 9Rank: 9

现货币
12 枚
在线时间
2195 小时
9#
发表于 2013-2-3 16:24:07 | 只看该作者
222222222222221
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

该用户从未签到

0

主题

314

帖子

0

贡献值

炉火纯青

Rank: 7Rank: 7Rank: 7

现货币
43 枚
在线时间
620 小时
10#
发表于 2013-2-3 16:46:25 | 只看该作者
看看,是什么东西
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

该用户从未签到

21

主题

319

帖子

0

贡献值

炉火纯青

Rank: 7Rank: 7Rank: 7

现货币
706 枚
在线时间
635 小时
11#
发表于 2013-2-3 16:47:07 | 只看该作者
一般!                     。。
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

签到天数: 43 天

[LV.5]常住居民I

11

主题

416

帖子

0

贡献值

炉火纯青

Rank: 7Rank: 7Rank: 7

现货币
1180 枚
在线时间
471 小时
12#
发表于 2013-2-3 16:53:39 | 只看该作者
[s:542]  [s:542]  [s:542]  [s:542]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

签到天数: 368 天

[LV.9]以坛为家II

520

主题

2478

帖子

65

贡献值

出神入化

Rank: 11Rank: 11Rank: 11Rank: 11

现货币
16122 枚
在线时间
6817 小时
13#
发表于 2013-2-3 17:17:19 | 只看该作者
[s:543]  [s:539]  [s:538]  [s:538]  [s:542]
现货海:遵纪守法 各抒己见 百家争鸣 创造价值

发表回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表

      <kbd id='IQ2QSp5tQ'></kbd><address id='IQ2QSp5tQ'><style id='IQ2QSp5tQ'></style></address><button id='IQ2QSp5tQ'></button>

              <kbd id='IQ2QSp5tQ'></kbd><address id='IQ2QSp5tQ'><style id='IQ2QSp5tQ'></style></address><button id='IQ2QSp5tQ'></button>